English Getting low FPS

12 replies
Goto Page
To the start Previous 1 Next To the start
31.01.10 07:20:24 pm
Up
Wraith
User
Offline Off
Ive played CS2D since 0104, and its been perfect the whole time i've played.

But since the most recent update (possibly earlier, i was inactive for a few months) i have been getting terribly low FPS.

I run cs2d, and on the main screen i get around 48FPS, when i open the serverlist it drops to 39-ish. Once im in a server it drops to 20-ish.

Now, sometimes it runs perfectly and i get 51 FPS, other times its terrible and i get 12FPS. I cant figure out what has changed? I already know that when i play with Fow my fps is lower than usual, but 20FPS?.. I'm assuming its not my computer because all the previous versions have run fine.

Its not any programs running in the background, and ive tried using the launcher to change the settings, nothing has worked. Previously if ive ever had problems with FPS (usualy with a new update) i simply turn the GFX as low as possible and it improves the performance 10-fold, usualy bringing my fps up to 50/51

DirectX mode runs with 20FPS (when in a server playing)
OpenGL mode just doesnt run at all, CS2D starts incredibly slowly, averaging 2FPS!! until CS2D shutsdown (the game wont run at 2FPS)

I have a bad laptop, slow CPU, bad ram and bad gfx card... But, All the other versions worked without this problem, so surely within the latest update the requirements are still the same?

Can anybody help?, its ruining my gaming
31.01.10 07:22:24 pm
Up
DC
Admin
Offline Off
CS2D now uses DirectX 9 instead of DirectX 7. Update your DirectX and video card drivers.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
02.02.10 04:24:45 pm
Up
Wraith
User
Offline Off
I have DirectX 9.0c now
and after driverdetective all my drivers are up to date

I'm still getting the same problem

Any other ideas?
02.02.10 04:27:34 pm
Up
Globetrotter
User
Offline Off
driverdetective button from windows?
Dont works.

Do you have Everest? So that you can tell me your hardware and i can tell you the driver's you need.

I'd rather be hated for who I am, than loved for who I am not.
02.02.10 07:08:42 pm
Up
Wraith
User
Offline Off
http://www.driverdetective.org.uk/ <- Driverdetective i used (free version i just searched for the missing drivers on google)

Laptop: Clevo M220S
OS: Windows XP (SP3)
Display Adapters: SiS 650_651_M650_M652_740
IDE Controllers: Primary IDE Channel, Secondary IDE Channel, SiS PCI IDE UDMA Controller
Processor: Intel Celron CPU 1.70GHz
Motherboard Chipset: SiS 650
3D Accelerator: SiS 315 Intergrated


The drivers i updated were:

Display Adapter: SiS 650_651_M650_M652_740
IDE Controller: SiS PCI IDE UDMA Controller
System: SiS Accelerated Graphics Port

If you need anymore info just tell me exactly what you need to know, but seen as my sound is perfect i would guess its something to do with my gfx card/gfx drivers.

Thx
02.02.10 08:49:52 pm
Up
Arghs-
User
Offline Off
Does the opengl mode works smoother?
IMG:http://www.pictureupload.de/originals/pictures/170210175121_zitat_ende.jpg
02.02.10 10:04:16 pm
Up
sonnenschein
User
Offline Off
Arghs- has written:
Does the opengl mode works smoother?

Omg, he already said that its really killing the FPS. Please don't say anything unless you have fully read the text.
02.02.10 11:36:28 pm
Up
Aura
User
Offline Off
On our main PC, its 14-20 FPS.
On my rather crappy labtop, its 18-25 FPS.

So I use OpenGL to run the game, but it crashes after its says "Conecting to U.S.G.N."...if I use my labtop...but thats 1.1.5, I'm gona' get 1.1.7 on my flash drive, I've also bin paching 1.1.5 with maps & stuff from "Counter-Strike 2D ALPHA_0.0.3.0", beleve that? thats ones old! The readme isnt even in English, but the game is. I also like a lot of the maps from it too, like "as_plane", & "cs_stranded"...But "CS2D ALPHA_0.0.3.0", doesnt work cuse I get this error: "Error! Can't initiale 3D at 640x480x32"
17.04.12 01:44:13 pm
Up
Tharontur
User
Offline Off
I Have directx 9 , but i play CS2D With 28 FPS, help!!
copycat - an user.
17.04.12 02:23:30 pm
Up
Bowlinghead
User
Offline Off
Try opengl or turn the advanced shadows off.
Share time limited free games here
17.04.12 02:25:50 pm
Up
Alistaire
User
Offline Off
user Aura has written:
On our main PC, its 14-20 FPS.
On my rather crappy labtop, its 18-25 FPS.


*Laptop

And what the fuck 20 FPS?
IMG:http://i.imgur.com/5zhwOTP.png
17.04.12 02:37:55 pm
Up
VAU
User
Offline Off
I have too ~30 FPS but its perfect, no stutters, no lags if my ping is good and the server is running well.
Sometimes I get a low FPS rate, when there are a lot of servers on the list, which mustload up. Also, when the server files are downloading, it lags, but there is no problem.

@user Tharontur: What PC specs have u?

Can ot be, that older Comps normally have 30 FPS like me and newer 50?

My Comp is running Windows 2000 SP2 with DirectX 8.2
17.04.12 03:11:30 pm
Up
Jynxxx
User
Offline Off
have you tried putting the color depth to 16 bit instead of 32 bit. works for my pc.
To the start Previous 1 Next To the start