English Lua script makes lag!!

12 replies
Goto Page
To the start Previous 1 Next To the start
24.01.12 06:39:21 pm
Up
Ahmad
User
Offline Off
Well, I’ve got a script, and although it works perfectly, it causes huge lag on my dedicated server.

The script itself is 33kb and the map is 146kb. Before I tested the new script, I used 4 scripts which add up to
30kb, on the same map, and there wasn’t much lag compared to the present lag. So, I’m not really sure why the lag is there.

I think there could be some kind bug or whatever in the script that’s causing the console to flood, although nothing like that seen when testing on a “New Game” server.
Here’s the script:

DELETED


Anyone who could fix whatever’s causing the problem would be greatly appreciated for their help.

EDIT:the god damn code thingy still doesn't work for me
EDIT2: now i got it , it was huge script , i had to make more than one code thingy.
edited 15×, last 24.02.12 03:28:36 am
24.01.12 06:41:15 pm
Up
TimeQuesT
User
Offline Off
Code:
1
2
3
4
addhook("always","wallhackfunction")
addhook("hit","vvz")
addhook("clientdata","xxas")
addhook("movetile","stuff")


edit:

user Ahmad has written:
I think there could be some kind bug or whatever in the script that’s causing the console to flood, although nothing like that seen when testing on a “New Game” server.


What messages do you receive?
edited 2×, last 24.01.12 06:45:51 pm
Muh
24.01.12 06:41:50 pm
Up
Kel9290
User
Offline Off
Do not use this script. Try something better as file cs2d Transcript Lua Experiment 1.07 [TLex] (66)
under the stone.
24.01.12 09:53:20 pm
Up
Ahmad
User
Offline Off
actually there is no msgs in the current script, sorry my bad
but there is sometimes when i check the logs i find
Lua error _ nail < or something like that
anyways the problem is the lag.
i hope u find what causing it
24.01.12 10:01:21 pm
Up
TimeQuesT
User
Offline Off
This error means that it trys to handle with "Nil" or "NULL" values. Better don't use this script. It's full of bugs.
The solution would be following Kel9290's advicement.
Muh
24.01.12 10:02:43 pm
Up
Ahmad
User
Offline Off
Thx,but Its for happy town server
25.01.12 12:16:10 am
Up
dizziness
User
Offline Off
No no no, Did you think? I am using my own citylife lua script for happy town and the result is same, dude There is no different even you using a wrong script for some map (I mean the result is the player still love it, eevn someone does not like it 100% :D)

TLex is better dude
dizziness from Indonesia! Visit our site: http://www.rajagame.com/ illegalWarning: If i'm rating your uploads it mean your uploads is perfect 5/5 or defect 1/5-4/5
25.01.12 01:30:31 am
Up
SilentDash
User
Offline Off
user Ahmad has written:
the problem is the lag.


just use a better root to host your server or delete the lua
25.01.12 07:50:23 pm
Up
Ahmad
User
Offline Off
it's hosted on oxy
and it wasn't lag before
maybe someone doesn't mind to read it all can fix it
25.01.12 07:57:55 pm
Up
Bobakrome
User
Offline Off
Well its lag cause that is edit of admin script, and that makes really lag, try do your own by scratch, and if ur "Your Mum" then U know i make it for you? No? -.-
25.01.12 08:41:53 pm
Up
Alistaire
User
Offline Off
Make your own scripts. They don't lag at all. And are way shorter. Afaik.
IMG:http://i.imgur.com/5zhwOTP.png
26.01.12 02:36:52 am
Up
Ahmad
User
Offline Off
@user Bobakrome: i don't really get you but "Your mum" made this not me,am ksa.
EDIT:oh Daxter,ur script has problem its only work for 1 admin

@user Alistaire: Only if i knew how
26.01.12 03:36:33 pm
Up
Bobakrome
User
Offline Off
user Ahmad has written:
@user Bobakrome: i don't really get you but "Your mum" made this not me,am ksa.
EDIT:oh Daxter,ur script has problem its only work for 1 admin

@user Alistaire: Only if i knew how


My script was working for 1 admin cause that was the only usgn that i put to be admin (LilGlitch3r) And yeah for now i was on duty at school so i made the script on my note.
To the start Previous 1 Next To the start