English CS2D Bug Reports

1,860 replies
Goto Page
To the start Previous 1 2 ... 10 11 12 ... 93 94 Next To the start
20.01.13 02:13:25 pm
Up
Jela331
User
Offline Off
I hate this bug. For example, I put a CS2D default sprite in the map, color it black and resize it so it would go over the whole map. I put trigger_start on that sprite. So, when I run the map, I can't see it. But when someone else joins the whole screen is black, if you restart then he wont see the black sprite.
26.01.13 12:12:31 pm
Up
JustARandomPlayer
User
Offline Off
i think this is a bug:i try to connect to a standard server and it stuck at "server is verifying your U.S.G.N. login..."

i let it half of hour and still server is verifying your U.S.G.N. login...

if i delet my username from option->net ,i can connect to the server and play...
26.01.13 12:34:45 pm
Up
Dynamite07
User
Offline Off
user JustARandomPlayer has written:
i think this is a bug:i try to connect to a standard server and it stuck at "server is verifying your U.S.G.N. login..."

i let it half of hour and still server is verifying your U.S.G.N. login...

if i delet my username from option->net ,i can connect to the server and play...

thats not a really bug, everyone have it when the server is in maintenance, some hacker is attacking the site... it happens too many times.
29.01.13 01:36:29 am
Up
D-D3ADxPro
User
Offline Off
This Bug Is Also Annoying. I go to the editor, I load up a map, save it, then I connect to a server, then the server won't let you connect.
Revisiting after 4 years, and boy how much cs2d really changed.
29.01.13 02:50:27 am
Up
zAzz
User
Offline Off
user D-D3ADxPro has written:
This Bug Is Also Annoying. I go to the editor, I load up a map, save it, then I connect to a server, then the server won't let you connect.


It happends to me all time, i just restart Cs2D.
IMG:http://steamsignature.com/status/english//76561198080739294.png
IMG:http://steamsignature.com/AddFriend.png
q miras capo
29.01.13 02:22:08 pm
Up
Starkkz
Moderator
Offline Off
Bots don't call the lua hook "join". I doubt they do call the hook "leave".
lol
11.02.13 08:40:48 am
Up
_oops
User
Offline Off
when turn on lighting in option and play server or
map then cs2d crash
this game was fun
11.02.13 04:35:26 pm
Up
Happy eyes
User
Offline Off
Server dedicated .exe doesn't create new lines, everything is printed in same line, so text is just wrapping. Image: IMG:http://i.imgur.com/I07ZXAK.png
12.02.13 02:49:55 pm
Up
Yates
Reviewer
Offline Off
The dedicated server does not load images when I start it, yet in-game the rest of the images work fine (I tried adding a timer to create the images later but that did not work). It works fine on new game so I guess this is a bug.
12.02.13 05:10:21 pm
Up
Mami Tomoe
User
Offline Off
Bugs:

Code:
1
2
When you die a lot of times you get empty glock / usp
When you left server some times this make you back to the server!
Is death truly a bad thing? If it is, then why do we all get to experience it? And... Why does it take so long? - What is the meaning of death?
13.02.13 04:56:44 am
Up
ItsAdamLY
User
Offline Off
user Jela331 has written:
I hate this bug. For example, I put a CS2D default sprite in the map, color it black and resize it so it would go over the whole map. I put trigger_start on that sprite. So, when I run the map, I can't see it. But when someone else joins the whole screen is black, if you restart then he wont see the black sprite.


Because Trigger_Start(s) contains nothing when starts but if you put trigger_start and triggered the Trigger_Delay to the sprite, the sprited will available timely.

More >
13.02.13 12:06:34 pm
Up
EpicP3nguin
User
Offline Off
Me and my friend SurfingGamer87
were playing normal construction with these 3 lua scripts:
LC
Unlimited Construction
TLex

So we started a normal match,later on i placed some turrets and when Surf came the turrets did not give him any damage
this is when it gets weird,
whenever i get infront of the turret and let it shoot me it shoots surf also the ammo pellets shoot out me when the turret shoots

but when we try CS2D without any lua's it still has the same result
Mafia joined and then he said when the turrets shoot him it heals him(this is not comfirmed)

Please try to find out what this bug is doing to CS2D
Thank You,
EpicP3nguin and Surf
13.02.13 12:27:13 pm
Up
Ahmad
User
Offline Off
@user EpicP3nguin: Maybe it's just one of these weird bugs that happens rarely, I know some bug that sometimes work and sometimes doesn't, I tried to preform it myself by I couldn't,it just happens randomly (It's with the teleport entrance and exit)
It's been there since version 0.9, too bad I haven't got the chance to record it but If it ever happened again I'll make sure to record it.
13.02.13 12:34:04 pm
Up
EpicP3nguin
User
Offline Off
user Ahmad has written:
@user EpicP3nguin: Maybe it's just one of these weird bugs that happens rarely, I know some bug that sometimes work and sometimes doesn't, I tried to preform it myself by I couldn't,it just happens randomly (It's with the teleport entrance and exit)
It's been there since version 0.9, too bad I haven't got the chance to record it but If it ever happened again I'll make sure to record it.


We Tested It 2 times in 2 different maps and had the same results
i think the bug is actually some loading error but i am not sure
13.02.13 01:11:27 pm
Up
DC
Admin
Offline Off
@user EpicP3nguin: Which game mode (cs2d cmd sv_gamemode) were you using?
I actually changed something related to the shooting function so it is possible that there are new bugs.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
13.02.13 01:14:11 pm
Up
EpicP3nguin
User
Offline Off
user DC has written:
@user EpicP3nguin: Which game mode (cs2d cmd sv_gamemode) were you using?
I actually changed something related to the shooting function so it is possible that there are new bugs.


The Gamemode was Construction
13.02.13 01:15:52 pm
Up
DC
Admin
Offline Off
Thank you I'll try to find and fix the problem.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
13.02.13 01:19:08 pm
Up
SurfingGamer87
User
Offline Off
user DC has written:
Thank you I'll try to find and fix the problem.

Also DC, idk if this might help but. I tried testing the turrets on Offline with Bots. And the issue (about the loss of sounds on turrets) is still present. But the bots get damaged by the turret.
13.02.13 02:58:42 pm
Up
Ahmad
User
Offline Off
Here's the bug I was talking about, After trying I found out how to do it.
Thanks to NoPain member nightway for recording n uploading to youtube.

I think it has something to do with internet connection cuz when I try it on my own server it doesnt work.

http://www.youtube.com/watch?v=67K8h46aKAI&feature=youtu.be

I tried to make the video as short as possible :S,I spelled teleport wrong.

PS: bug was there since version 0.8, and it doesn't work when something blocks the door.
Once It worked on like 5 tiles between entrance and exit and there wasn't a door just a bunch of walls,in version 0.8 or 0.9.
14.02.13 08:25:18 pm
Up
wotaan
User
Offline Off
I have a problem with NPCs, they turn into red squares.
When it started, i think its because my map is big. But i saw some guys who have some problem with me.
@user BetaM: explained why thats happening. if he is right, i think its not that hard to fix
@user DC: if u can fix this bug too, it will be great

user BetaM has written:
...
> When a player leaves the server, the NPC's with the same type as the player's ID (for example Headcrabs for ID 2) turn into red squares (invalid NPC's)
...


IMG:http://x-gameservers.net/svlist/cs2d/109.73.77.38:35115.png
IMG:http://rj.revolvermaps.com/h/b/26/91hkrxy2xvp.png
To the start Previous 1 2 ... 10 11 12 ... 93 94 Next To the start