English new Bots update by Loooser icon

81 comments
03.01.11 06:39:24 pm
like 54 like it!
14 kb, 1,825 Downloads
Loooser
User
Offline Off
This is the new bots update with the lagg fixed.moreover they have many more features like knifing players with melees when they are in range. i also started making bot build inteligent. of cause you can change the skills with the settings skills.cfg file. They spray logos and use more radio msgs.

Here you can see in which order the bots attack the enemies

Rank 1
player
rank 2
npcs
rank 3
turret
rank 4
other buildings
imageimageimage
ok This file has been reviewed and approved by Infinite Rain (04.12.15 01:35:18 am)

Comments

81 comments
Goto Page
To the start Previous 1 2 3 4 5 Next To the start

Log in!

You need to log in to be able to write comments!Log in
27.07.15 10:10:25 am
Up
HoOtix
User
Offline Off
Dangit How do u use this...
02.07.13 01:36:31 pm
Up
gtadrakon007
User
Offline Off
[14:28:45] LUA ERROR
(ai_update_living): bots/
Standard AI.lua:245: attempt to
compare number with boolean
[14:28:45] Freezing bots to stop
Lua error msg flood! Use
'bot_freeze 0' to unfreeze bots!
plaes build bot update of cs2d 0.1.2.2
26.05.13 11:15:25 am
like I like it!
Up
Rattle189
User
Offline Off
I have the same problem with @user Combine Soldier Macro: When a bot kills an NPC they freeze and when I view the console I see these 2 red lines

---
[Time] LUA ERROR (ai_update_living): bots/Standard AI.lua:245: attempt to compare number with boolean
[Time] Freezing bots to stop LUA error msg flood! Use 'bot_freeze 0' to unfreeze bots!
---

Please fix this Loooser and we'll be so happy. I'll need this for my server
14.04.13 06:04:31 pm
like I like it!
Up
when a bot kills an npc they freeze and it appears

[12:53:37] LUA ERROR (ai_update_living): bots/Standard AI.lua:245: attempt to compare number with boolean
[12:53:37] Freezing bots to stop Lua error msg flood! Use 'bot_freeze 0' to unfreeze bots!
12.04.13 02:18:03 am
like I like it!
Up
okeyman
User
Offline Off
Like it Wiiinner
18.03.13 11:07:21 pm
like I like it!
Up
Avo
User
Offline Off
Masterpiece.
16.02.13 11:12:17 pm
like I like it!
Up
TK Gunz FBI
User
Offline Off
Nice Job! A 9/5
11.02.13 10:25:45 am
like I like it!
Up
RichNagel
User
Offline Off
Hey Loooser,

Any chance of updating your bots with the new "flashbang" feature of the new version of CS2D (Beta 0.1.2.2)?

The new version of the game makes it so that the bots are ALSO blinded by a flashbang (like humans are).
28.12.12 02:55:34 pm
like I like it!
Up
TheBosS_
User
Offline Off
Looser, all of your lua scripts are great

Liked it.
27.12.12 07:52:33 am
like I like it!
Up
RichNagel
User
Offline Off
LOVE these new bots, Looser!

Like the other poster commented, they still don't use the teleporters. But otherwise, GREAT JOB


(EDIT) One little bug report, Looser:

Any time that I issue the radio command "Enemy Down", the bots completely freeze, and won't move again until the map cycles (or I stop the current game, and then start it again).

Here's the info that I see in my console logs:

Code:
1
2
LUA ERROR (ai_hear_radio): bots/Standard AI.lua:767: table index is nil
Freezing bots to stop Lua error msg flood! Use 'bot_freeze 0' to unfreeze bots!



By the way, I also tested it with the older version of your bots ( http://www.unrealsoftware.de/files_show.php?file=3758 ), and had the same problem. Here's the info that I see in my console logs for that older version (similar error message, different line number):

Code:
1
2
LUA ERROR (ai_hear_radio): bots/Standard AI.lua:634: table index is nil
Freezing bots to stop Lua error msg flood! Use 'bot_freeze 0' to unfreeze bots!



(EDIT #2) With as little as I know about Lua scripting, I think I may have found the problem.

I took a look at these lines in the "Standard AI.lua" file:

Code:
1
2
3
4
5
6
7
8
9
10
-- Enemy spotted / Taking fire, need assistance
        elseif radio==9 or radio==11 then
                local mate=fai_randommate(source)
                if mate~=0 then
                        if math.random(1,2)==1 then vai_radioanswer[mate]=0 else vai_radioanswer[mate]=28 end
                        vai_radioanswert[mate]=math.random(35,100)
                        vai_mode[mate]=2
                        vai_destx[mate]=player(source,"tilex")
                        vai_desty[mate]=player(source,"tiley")
                end


...and compared them to these lines in the file (note that the "--enemy spotted" and "radio==8" lines below (radio message "8"), are ACTUALLY the "Enemy Down" radio message, and NOT the "Enemy Spotted" radio message "9" that I used for comparison above). The "vai_destx[id]=player(source,"tilex")" line below is line 767 (as referenced in the error message that I refered to previously):

Code:
1
2
3
4
5
6
7
8
9
10
--enemy spotted
        elseif radio==8 then
                 local mate=fai_randommate(source)
                 if mate~=0 then
                    if math.random(1,2)==1 then vai_radioanswer[mate]=0 else vai_radioanswer[mate]=28 end
                        vai_radioanswert[mate]=math.random(35,100)
                        vai_destx[id]=player(source,"tilex")
                        vai_desty[id]=player(source,"tiley")
                        vai_mode[id]=2
                 end


I then edited the above to look like this:

Code:
1
2
3
4
5
6
7
8
9
10
--enemy spotted
        elseif radio==8 then
                 local mate=fai_randommate(source)
                 if mate~=0 then
                    if math.random(1,2)==1 then vai_radioanswer[mate]=0 else vai_radioanswer[mate]=28 end
                        vai_radioanswert[mate]=math.random(35,100)
                        vai_destx[mate]=player(source,"tilex")
                        vai_desty[mate]=player(source,"tiley")
                        vai_mode[mate]=2
                 end


...and the bots seem to work perfectly, with no error messages displayed in the console
edited 4×, last 27.12.12 08:37:02 pm
25.10.12 05:02:56 pm
Up
Loooser
User
Offline Off
I will work on it
03.09.12 06:16:45 pm
like I like it!
Up
YoshiSmb
User
Offline Off
hey looser! can update the bots abilyt?
they dont use teleport
can fix that?
you get 5/5 good work!
02.09.12 01:24:34 pm
Up
TopNotch
User
Offline Off
My bots don't respawn, and when i do restart they are just freezed.
01.09.12 04:37:45 pm
like I like it!
Up
mattasha
User
Offline Off
Nice But When i have downloaded it i use it in my sv
All BOTS not mooving like (FREEZED,Scared)
Edit it Good Luck
18.07.12 12:53:50 pm
like I like it!
Up
agash1999
User
Offline Off
go to se-x.come
03.06.12 01:01:00 am
Up
PbBOKAN
User
Offline Off
bots attacking their own turrets, must fix that...
27.04.12 06:26:33 pm
Up
Enderwarrior - RUS
User
Offline Off
user SkullzOrig: same problem...
21.04.12 10:08:55 pm
Up
SkullzOrig
User
Offline Off
@user Loooser: I have used your bots before, but problem is after a while they stop moving,shooting,and they would not even spawn.
21.04.12 04:33:50 pm
like I like it!
Up
_MARKOS_
BANNED
Offline Off
new bots
18.04.12 04:59:02 pm
like I like it!
Up
ZeitgeistEND
User
Offline Off
very nice
To the start Previous 1 2 3 4 5 Next To the start