English CS2D Bug Reports

1,813 replies
Goto Page
To the start Previous 1 2 ... 19 20 21 ... 90 91 Next To the start
19.02.14 04:15:45 pm
Up
TopNotch
User
Offline Off
Hello, this bug occurs when I look at my LAN list (tab).

That's how the bug works:
When I open the server list, a random server shows up in my LAN list.
When I refresh the LAN list, the list is just empty.
When I refresh the server list, the LAN list will still have the same server in it.
When I close the server list (window), and open it again, another random server appears in my LAN list.


• Some screenshots and information about those servers:

Spoiler >


NOTE: I was running CS2D on Linux, this doesn't occur when I'm using Win7.
20.02.14 07:12:40 pm
Up
Yates
Reviewer
Offline Off
Spawning a projecttile on player x, y while dead crashes the server. The same probably goes for spawning an item I guess, not tested yet.
12.03.14 12:09:55 am
Up
Ahmad
User
Offline Off
This has been mentioned long time ago but I think it has been forgotten.
user SD has written:
Many people here have trouble connecting to USGN. Some restart CS2D, some go to net settings, removing one word from login/password, then typing it again. I suggest a button in main menu (preferably under USGN status) which will reconnect you to USGN. Not a simple login check, but dropping all the incoming & outcoming packets and sending them to USGN again.

the problem still there and It's really annoying, it needs to be fixed immediately.
12.03.14 10:58:49 am
Up
DC
Admin
Offline Off
It's (normally) not necessary to repeat bug reports. I'm aware of the problems and I already worked on them but they still seem to be there for some people and I don't really know why. That's the point. But I'm aware of it and I'll keep trying to fix it.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
12.03.14 11:55:34 am
Up
nikolaXX
User
Offline Off
there is also a glitch that sometimes the tiles or blocks you place they lighten than darken in a map editor
14.03.14 11:09:36 pm
Up
VADemon
User
Offline Off
Why does the client still receive chat messages after disconnecting?
http://imgur.com/doZafiL
15.03.14 10:32:27 pm
Up
Ahmad
User
Offline Off
@user DC: Can you please add a reconnect button as a hot fix, it shouldn't be hard.
This is really really annoying, every time i change servers i have to restart cs2d.
17.03.14 05:52:24 pm
Up
Rainoth
Moderator
Offline Off
Code:
local img = tile(x,y,"frame")
Player[id].glowimage = image("<tile:"..img..">", 0, 0, 200+id)

Result :
IMG:http://screencloud.net/img/screenshots/0c47cb6ef2b630e9d7496e46f2d095ed.png


In case the image is so stubborn so as not to appear, the tile spawns at the center of the player and goes from there on, instead of centering itself in the middle like all the images with mode 200+id
18.03.14 01:59:15 pm
Up
Yates
Reviewer
Offline Off
cs2d cmd spawnplayer crashes the server when used on spawn. Yeah I know I should have used setpos (thought I did actually). But at least disable this sneaky little error to occur
18.03.14 02:59:51 pm
Up
DC
Admin
Offline Off
@user Ahmad: Yes, I already implemented a U.S.G.N. force re-login button for the next release.

@user Rainoth: That's (semi) intended behavior. I won't change it in order not to break existing scripts. I'll add a note about that in the online reference of cs2d lua cmd image! Or should I center them only when they are drawn at a player? ...

@user Yates: You seriously tried to spawn a player while it's spawned? This causes an infinite loop (and probably additional bugs) and there are also several other cases with other hooks+commands which cause the same problem. It's a general obvious/logical problem. Maybe I'll think about a system to block/ignore certain commands with an error message under certain circumstances but this has low priority on my todo list.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
18.03.14 03:12:33 pm
Up
Rainoth
Moderator
Offline Off
Quote:
Or should I center them only when they are drawn at a player?

Yes please. If not, I just have to use mode 1/3 and imagepos it upon move but if it's not too much to work on, it would be greatly appreciated.

EDIT : I mean, it's only logical that mode 100+id/200+id would work the same for all images, right ?
18.03.14 03:14:24 pm
Up
Yates
Reviewer
Offline Off
user DC has written:
@user Yates: You seriously tried to spawn a player while it's spawned?

It seems so. I'm pretty sure I changed it into setpos a while ago but that was around the time my laptop crashed so it didn't save. Took me a while to find that bug though, it's just something people tend to overlook.
29.03.14 03:25:47 pm
Up
Infinite Rain
Reviewer
Offline Off
Sorry if that was posted before, I don't want to read 20 pages of threads just to know if it was. Anyway, game('sv_gm') doesn't return anything. I'm pretty sure that this is a bug.
A thousand may fall at your side, ten thousand at your right hand, but it will not come near you. You will only look with your eyes and see the recompense of the wicked. - Psalm 91:7-8 ESV
29.03.14 03:55:36 pm
Up
DC
Admin
Offline Off
Some commands have aliases. Only the original commands work. Se cs2d cmd sv_gamemode - so cs2d lua cmd game('sv_gamemode') should work. I also updated the documentation now to clarify this point.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
17.04.14 04:16:28 pm
Up
Pseudon
User
Offline Off
Alright,this is what happened to me,I just played I deathrun map that was using Lua file,in maps,but when I changed the map,the entities were not removed,so the dyn_walls and the spawns were not reset,after that I noticed that the map I tried to play had no spawn entities,the question is. Why that happened? How the map was working? Why I didn't got disconnected?
*Empty*
19.04.14 11:59:30 am
Up
MikuAuahDark
User
Offline Off
What's wrong with this?

There's just a checkbox without any text.
file cs2d LuaJIT for Dedicated Server (11) JIT POWER! | Know your Lua errors! | Draw stuff at Pixelize Art --xx-- server!
19.04.14 01:55:24 pm
Up
Ven0m
User
Offline Off
I downloaded the new version today and i tried to log in and its not stoping sayin trying to log in im so sad about that i can't do anything about it,i can play but my account is not working
19.04.14 09:16:17 pm
Up
Pseudon
User
Offline Off
@user MikuAuahDark: I think it's because of your CS2D,I don't have that problem,try to reinstall your game.
*Empty*
26.04.14 10:14:13 am
Up
useigor
User
Offline Off
1.) Cyrillic symbols of language translation (in UTF-8 encoding) that appear in logs, behave like cyrillic in chat — C; 83@C
2.)Missing strings. I also noticed that in title (img #2) string #0099 changes to "Servers". It's clearly noticeable in any language, except the English. In img #1 titles are english.
IMG:http://s09.radikal.ru/i182/1404/5a/211a29123629.jpg
edited 1×, last 26.04.14 10:30:03 am
27.04.14 07:18:05 pm
Up
TopNotch
User
Offline Off
I don't know if this is either a CS2D bug or my computer.
It happened to me a several times, fixed after rebooting my computer.

IMG:http://s3-eu-west-1.amazonaws.com/screenshooter-legacy/ra-tpaqfcgqczxnfoqcaxkr.jpg
To the start Previous 1 2 ... 19 20 21 ... 90 91 Next To the start