English CS2D Takes 100% of CPU Usage

13 replies
Goto Page
To the start Previous 1 Next To the start
17.01.12 04:39:30 pm
Up
ParaBolt
User
Offline Off
The title says it all : I've never examined CS2D Process in a Task Manager but recently I'm having problems of low FPS (yea I read all those threads regarding it.) And I checked it in Task Manager. I see that it occupies 100% of CPU Usage. Is this supposed to happen or my CPU contains viruses or .. ?

My CPU System Specs :-

OS - MS Windows XP Professional 32-bit SP3
Processor - Intel(R) Celeron(R) M processor 1.50GHz
RAM - 256 MB Single-Channel DDR2 @ 99MHz (3-3-3-9)
Motherboard - Acer Mimid (uFCPGA)
Graphics - Mobile Intel(R) 915GM/GMS,910GML Express Chipset Family [128 MB]

And yes, it worked fine in my PC a few days ago. This FPS thing also occurred suddenly. Also whenever turrets are used (like 8 or so) my FPS suddenly drops to 2 or 1 and my game closes automatically. Sometimes I also get an error message EXCEPTION_ACCESS_VIOLATION.

Please help me. Thank you.
edited 1×, last 17.01.12 04:55:53 pm
17.01.12 04:42:39 pm
Up
Kel9290
User
Offline Off
yeah, too many shooting turrets will cause closing game. i have same thing.
under the stone.
17.01.12 04:48:57 pm
Up
oxytamine
User
Offline Off
user ParaBolt has written:
OS - MS Windows XP Professional 32-bit SP3

First of all...
17.01.12 04:52:45 pm
Up
DannyDeth
User
Offline Off
user ParaBolt has written:
Processor - Intel(R) Celeron(R) M processor 1.50GHz
RAM - 256 MB Single-Channel DDR2 @ 99MHz (3-3-3-9)
[...]
Graphics - Mobile Intel(R) 915GM/GMS,910GML Express Chipset Family [128 MB]

Slow, old processor ( we are talking senile, here ), almost no RAM, and a graphics card that makes Intel look like a bunch of codgers in labs suits.

That right there is your problem.
17.01.12 04:54:01 pm
Up
Silent_Control
User
Offline Off
user oxytamine has written:
user ParaBolt has written:
OS - MS Windows XP Professional 32-bit SP3

First of all...


Windows XP is fine.

@user ParaBolt: Do you run CS2D in DirectX or OpenGl?
DC has written:
I don't even have birthday and writing a title in capital letters is stupid. closed.
This was wrote in mrlightcorn's thread "Happy birthday, DC!". So that means that DC does not have a birthday?
17.01.12 04:58:04 pm
Up
ParaBolt
User
Offline Off
@Oxytamine : Edited the post
@Yates : I know my lap old BUT IT WORKED FINE BEFORE. NO FPS DROPS AND SMOOTH GAMEPLAY (*_*).
@Silent_Control : I run it in DirectX. I'll try OpenGL thx.

@All repliers : Thanks for your help dudes!
17.01.12 05:00:12 pm
Up
Time
User
Offline Off
It is not very often that I see people mistake Danny for Yates
edited 1×, last 17.01.12 05:00:40 pm
IMG:https://sc-cdn.scaleengine.net/i/3a137042de3c79a4d3c69b1f036866e92.jpg
17.01.12 05:00:32 pm
Up
oxytamine
User
Offline Off
user Silent_Control has written:
Windows XP is fine.

No it is not.
17.01.12 05:01:59 pm
Up
Time
User
Offline Off
Everyone bitched about vista when w7 wasn't out, now they bitch about xp
IMG:https://sc-cdn.scaleengine.net/i/3a137042de3c79a4d3c69b1f036866e92.jpg
17.01.12 05:42:41 pm
Up
DC
Admin
Offline Off
nope, 100% cpu usage is absolutely uncommon and it shouldn't happen!

if you run the server yourself: check your Lua scripts.

if not: undo recent changes on your system. like running new software in the background (anti virus, firewall, etc) and system updates. especially video card drivers. also use lower particle details.

of course windows xp is NOT the reason for this and it would be the dumbest idea EVER to upgrade to vista or 7 with such a super weak system. it's simply too slow for 7 so xp (or 2000) is actually the best windows version for this system.

randomly saying that a certain OS is crap doesn't help anyone so please stop it.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
18.01.12 01:54:48 am
Up
MikuAuahDark
User
Offline Off
user ParaBolt has written:
OS - MS Windows XP Professional 32-bit SP3
Processor - Intel(R) Celeron(R) M processor 1.50GHz
RAM - 256 MB Single-Channel DDR2 @ 99MHz (3-3-3-9)
Motherboard - Acer Mimid (uFCPGA)
Graphics - Mobile Intel(R) 915GM/GMS,910GML Express Chipset Family [128 MB]

WinXP works fine
Your processor is good
The ram is the problem. buy a new ram, cs2d need 1gb of ram
Motherboard good
This is problem too, your chipset is too low
you need these specification below to play cs2d:
Requirements has written:
Recommended system requirements for the CS2D client are:
• 256 mb 3D video card with DirectX 7+ OR OpenGL support
• 1 ghz CPU and 1 gb RAM (2 gb RAM recommended for Vista/7)
• 30 mb free disk space (more recommended for downloads!)
• Win 2000, XP, Vista, 7 OR Linux OR MacOS 10.3.9+


user ParaBolt has written:
And yes, it worked fine in my PC a few days ago. This FPS thing also occurred suddenly. Also whenever turrets are used (like 8 or so) my FPS suddenly drops to 2 or 1 and my game closes automatically. Sometimes I also get an error message EXCEPTION_ACCESS_VIOLATION.

this is happend with all people(maybe another can more or less than 8 turret) and caused by low ram
file cs2d LuaJIT for Dedicated Server (13) JIT POWER! | Know your Lua errors! | Part of LÖVE development team since 11.3
18.01.12 01:57:05 am
Up
Apache uwu
User
Offline Off
hmm I'd try openGL then directX...

--also make sure you're not running any "extensive" lua scripts
18.01.12 06:52:13 am
Up
ParaBolt
User
Offline Off
Thanks guys!

Anyways I think my installer was corrupt o.o

I downloaded a ZIP Archive from Unreal Software Archives and extracted it on a new location. Now my CS2D works fine
18.01.12 12:10:50 pm
Up
DC
Admin
Offline Off
super weird.. it should either work or don't work at all if the download/installer is corrupted...

whatever.. glad to hear that it works now
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
To the start Previous 1 Next To the start