English Servertransfer.lst bugged!

10 replies
Goto Page
To the start Previous 1 Next To the start
28.04.15 05:03:37 pm
Up
The Gajos
BANNED
Offline Off
Why when I start my server at VPS (linux), the server won't load servertransfer.lst ?
The file is set right so I don't see any reason to this doesn't work.
28.04.15 05:47:57 pm
Up
VADemon
User
Offline Off
And I don't see any reason not to publish its contents.
28.04.15 08:04:55 pm
Up
DC
Admin
Offline Off
Those thousands of accounts are Off-Topic. He comes back anyway so I'll tolerate that unless he violates the rules again.

@user The Gajos: Please provide the following three things:
• your servertransfer.lst (post all of its contents)
• accurately describe what you want to happen
• accurately describe what actually happens (e.g.: files not transferred, error messages, ...?)

And here one thing I can already tell you without getting any information from you: CS2D clients have download size restrictions by default. Go to the net options in the client to see them. So keep your files small or nobody (with default settings) will be able to load them.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
28.04.15 08:24:31 pm
Up
GeoB99
Moderator
Offline Off
Your image is a bit meaningless because it doesn't show anything regard this problem about the servertransfer.lst (since I saw is all fine here in that screen).

Try to follow the user DC's option and make sure your servertransfer file is not damaged.
28.04.15 09:14:33 pm
Up
The Gajos
BANNED
Offline Off
So it looks like cs2d_dedicated won't read the file but there aren't any errors. Btw. I think if we put anything to the servertransfer file, player can't don't download them (just must download from my experience) and I've tested this way of course.
I think it's not bug in cs2d client but cs2d_dedicated because it doesn't say "added file" or "can't add file", it just ignore that file .

The cs2d_dedicated version shall be good because I can join to the server and when I run the Windows cs2d_dedicated at Linux via wine it works fine. I can't run Linux's applicstion of cs2d, don't know why because me appear a PyPar2 window lol.
28.04.15 09:25:14 pm
Up
DC
Admin
Offline Off
It definitely works on dedicated servers too. Many people are using this feature on their servers. So your file or your settings must be wrong.

• Make sure that the file is in your sys folder (it is possible that you changed the location/name of that folder in the settings)

• Make sure that it is saved as ANSI/ASCII file and NOT as a file with UTF-8 or any other encoding!

• Doublecheck the name of the file. servertransfer.lst (.LST [for list] in small letters, not .IST)

In case of doubt: Insert the original file from the CS2D download and edit it.

By the way: What editor/tool do you use to edit the file? It might destroy the encoding or whatever. I hope you don't use Word or something like that.

Also you still did not provide your file so we can't check it for errors. It's not easy to help you if you provide so limited information.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
29.04.15 06:36:30 pm
Up
The Gajos
BANNED
Offline Off
user DC has written:
So your file or your settings must be wrong.

I don't know what's setting it's.

So look at the so fuckin' big screenshot: http://i.imgur.com/HMEFm46.png
and tell me if in notepad the instructions are right (I think these lines shouldn't be as a single line :v).

Ps. the screenshot with grey background is from Notepad++.
edited 1×, last 29.04.15 06:55:29 pm
02.05.15 07:57:29 pm
Up
Ajmin
User
Offline Off
i think theres some cmd like sv_transfer or else.
Maybe maptransfer im nt sure..
02.05.15 09:40:55 pm
Up
DC
Admin
Offline Off
@user The Gajos: Yes, your linebreaks are fucked up because you used the wrong encoding or the wrong linebreak character in another editor.

Either find a way to change that using Notepad++ (or whatever) or save as ANSI, add linebreaks manually and save again in ANSI.

The normal text editor has to show the linebreaks correctly.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
02.05.15 11:58:20 pm
Up
TimeQuesT
User
Offline Off
The problem is pretty obvious: your editor saved 'new lines' just as LF (line feed [\n]), but in Cs2d ( and common in windows) it's saved as CR (carriage return [\r]) + LF [\r\n].

Just use notepad and add 'new line' manually to fix that.

Edit:
alternatively you can use THIS tool.

Just drag & drop the textfile over it and it is repaired. (make a backup first)

For teh trusts >
edited 2×, last 03.05.15 12:13:06 am
Muh
To the start Previous 1 Next To the start