English Dedicated Server CL Arguments Error?

2 replies
Goto Page
To the start Previous 1 Next To the start
Offline Off
Hello buddies!

I'm working on some kind of "school project", I'm trying to bring up a high availability cluster webpanel that automatically turns on services on different machines depending on the loads, server players in this case, etc....

The thing is that I was trying to automatically install and run a cs2d dedicated server on a Ubuntu Server when I found this problem:
- If I run the dedicated server with command line with an argument, it somehow resets other arguments that I don't wanna pass to the launcher.
I mean that I run "cs2d_dedicated -port 36963" per example and the console says:
Server Console has written:
Starting server...
load map ''
LOAD MAP: 'maps/.map' does not exist
Trying to load map from mapcycle...
No map loaded! Check your configuration!

I want the server to run every single time on the port that my server specifies with a PHP variable from a database. The -port launch argument looked really nice until I saw it's forcing me to specify a map using arguments too...

I hope someone can help me with this.
Meanwhile, I'll be replacing sv_hostport with the port I want, using "sed" every single time someone "starts" the server.
03.06.19 07:10:37 pm
Offline Off
This is a bug apparently. Makes no sense that it behaves like that.
Will be fixed for the next release.

To deal with that issue manually you would have to read sys/server.cfg, find the line starting with "map " and pass the value behind that to the server as parameter.

Or you just specify another map manually.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
05.06.19 12:32:29 pm
Offline Off
That's a nice idea to deal with it meanwhile.

Thank you for your support.
To the start Previous 1 Next To the start