English Can't see my server on the server list

5 replies
Goto Page
To the start Previous 1 Next To the start
Up
ErgoUser
User
Offline Off
Hello, i still can't find my server on the server list, and I am not the only one.
Its also weird that it only happens to certain people.
26.11.22 10:12:04 am
Up
DC
Admin
Offline Off
Hi there,

this is a very common problem. Therefore it's covered by the FAQ:
https://www.cs2d.com/faq.php?show=net_noentry#net_noentry

If this doesn't help I recommend to also read this thread:
thread cs2d Server Setup: Guide / Checklist

p.s.: Please try to use the right section when creating threads. Moved this one from "Unreal Software" to "CS2D Servers".
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
26.11.22 04:03:08 pm
Up
ErgoUser
User
Offline Off
@user DC:

Its a dedicated server, I'm hosting it from a virtual machine

I opened all the ports
sv_lua 0

I found the server on the list, but just its ip 91.196.231.152:36963 it doesn't show the name
26.11.22 04:23:29 pm
Up
MaksDragon
User
Offline Off
@user ErgoUser: what hosting do you use? and its debian? ubuntu?
IMG:https://www.gs4u.net/en/350x20/s/242021.png
26.11.22 08:10:34 pm
Up
DC
Admin
Offline Off
The sv_lua setting isn't really relevant for server list / connectivity. sv_lan is the important one - but it's already set to the correct value if your server's IP is in the list.

That virtual machine is running on your local PC / network? It's almost certainly a problem with your router and/or firewalls. In this particular case it might even be caused by settings of the virtual machine (I guess you have to expose the ports in some way as well).

Unfortunately it depends a lot on used hard- and software so I can't provide a step by step instruction for this (plus I never tried to host a server from within a VM).

General things to consider:
• port forward the used UDP port correctly in your router (only required if you run the server from within our own home network and if you're using a router)
• make sure that no firewall blocks the traffic (software firewalls like the built-in windows firewall, hardware firewalls in routers etc.)
• make sure the VM exposes the used UDP port correctly (I guess)

https://www.cs2d.com/faq.php?show=net_nojoin#net_nojoin
and thread cs2d Port Forward primer!
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
27.11.22 04:24:51 am
Up
MikuAuahDark
User
Offline Off
If you're hosting through VM, ensure the port 36963 is forwarded from the VM to your host PC AND listens at 0.0.0.0.

To test if it works, try to connect to your server with the router IP (not 127.0.0.1). If it works then continue to standard port forwarding checklist for your host PC as user DC given.
file cs2d LuaJIT for Dedicated Server (13) JIT POWER! | Know your Lua errors! | Part of LÖVE development team since 11.3
To the start Previous 1 Next To the start